use strict;
my $str = 'https://youtube.com
https://www.amazon.com
https://www.notamazon.com
';
my $regex = qr/(((https?:(?:\/\/)?)(?!(www\.)*youtube\.com|youtu\.be|(www\.|rover\.)*ebay\.com|(www\.)*amazon\.)[A-Za-z0-9.\-]+[A-Za-z0-9.\-]+)((?:\/[\+~%\/.\w\-_]*)?\??(?:[\-\+=&;%@.\w_]*)#?(?:[\w]*))?)/mip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}