#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:(?:i|sir|ami|snap|vol|ssi|Ipv4)\b(?:-[a-zA-Z0-9]+)?|(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?:\s*,\s*(?:[0-9]{1,3}\.){3}[0-9]{1,3})*)\b"
Local $sString = "i-XXXX, sir-XXXX, ami-XXXX, vol-XXXX, snap-XXXX, 123.123.123.123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")