import re
regex = re.compile(r"\b(?:(?:i|sir|ami|snap|vol|ssi|Ipv4)\b(?:-[a-zA-Z0-9]+)?|(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?:\s*,\s*(?:[0-9]{1,3}\.){3}[0-9]{1,3})*)\b", flags=re.MULTILINE)
test_str = "i-XXXX, sir-XXXX, ami-XXXX, vol-XXXX, snap-XXXX, 123.123.123.123"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")