using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?:i|sir|ami|snap|vol|ssi|Ipv4)\b(?:-[a-zA-Z0-9]+)?|(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?:\s*,\s*(?:[0-9]{1,3}\.){3}[0-9]{1,3})*)\b";
string input = @"i-XXXX, sir-XXXX, ami-XXXX, vol-XXXX, snap-XXXX, 123.123.123.123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}