re = /\b(?:(?:i|sir|ami|snap|vol|ssi|Ipv4)\b(?:-[a-zA-Z0-9]+)?|(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?:\s*,\s*(?:[0-9]{1,3}\.){3}[0-9]{1,3})*)\b/m
str = 'i-XXXX, sir-XXXX, ami-XXXX, vol-XXXX, snap-XXXX, 123.123.123.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end