// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:(?:i|sir|ami|snap|vol|ssi|Ipv4)\b(?:-[a-zA-Z0-9]+)?|(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?:\s*,\s*(?:[0-9]{1,3}\.){3}[0-9]{1,3})*)\b").unwrap();
let string = "i-XXXX, sir-XXXX, ami-XXXX, vol-XXXX, snap-XXXX, 123.123.123.123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}