import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:i|sir|ami|snap|vol|ssi|Ipv4)\\b(?:-[a-zA-Z0-9]+)?|(?:[0-9]{1,3}\\.){3}[0-9]{1,3}(?:\\s*,\\s*(?:[0-9]{1,3}\\.){3}[0-9]{1,3})*)\\b";
final String string = "i-XXXX, sir-XXXX, ami-XXXX, vol-XXXX, snap-XXXX, 123.123.123.123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}