using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\d{1,2}\s*(?:h|m))(?:(\d{1,2})\s*h)?\s*(?:\s?(\d{1,2})\s*m)?";
string input = @"8h20m 10m 8h left
8 h 30 m left
8h left
8h 20m left
57m left
1m left";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}