const regex = /(?=\d{1,2}\s*(?:h|m))(?:(\d{1,2})\s*h)?\s*(?:\s?(\d{1,2})\s*m)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\d{1,2}\\s*(?:h|m))(?:(\\d{1,2})\\s*h)?\\s*(?:\\s?(\\d{1,2})\\s*m)?', 'g')
const str = `8h20m 10m 8h left
8 h 30 m left
8h left
8h 20m left
57m left
1m left`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}