$re = '/(?=\d{1,2}\s*(?:h|m))(?:(\d{1,2})\s*h)?\s*(?:\s?(\d{1,2})\s*m)?/';
$str = '8h20m 10m 8h left
8 h 30 m left
8h left
8h 20m left
57m left
1m left';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);