import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\d{1,2}\\s*(?:h|m))(?:(\\d{1,2})\\s*h)?\\s*(?:\\s?(\\d{1,2})\\s*m)?";
final String string = "8h20m 10m 8h left \n"
+ " 8 h 30 m left\n"
+ "8h left\n"
+ "8h 20m left\n"
+ "57m left\n"
+ "1m left";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}