using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https:|http:|www\.)\S*";
string input = @"3333-768-0948
1133.168.0248
7678*999-8978
https://google.com/q=search
http://google.com/q=search
httpq://google.com/q=search
www.google.com
www.google.com/?search=qppoao
www . google.com/?search=qppoao
https : //google.com/q=search
https://www.google.com
http://www.google.com
www.google.com
htt://www.google.com
://www.google.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}