const regex = /^(https:|http:|www\.)\S*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https:|http:|www\\.)\\S*', 'gm')
const str = `3333-768-0948
1133.168.0248
7678*999-8978
https://google.com/q=search
http://google.com/q=search
httpq://google.com/q=search
www.google.com
www.google.com/?search=qppoao
www . google.com/?search=qppoao
https : //google.com/q=search
https://www.google.com
http://www.google.com
www.google.com
htt://www.google.com
://www.google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}