using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"target1 = (?<target1>\w+).*\ntarget2\s+(?<target2>\w+)";
string input = @" john smith (ABCDEFG) <js@email.com>
target1 = 3333, j
target2 1111,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}