const regex = /target1 = (?<target1>\w+).*\ntarget2\s+(?<target2>\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('target1 = (?<target1>\\w+).*\\ntarget2\\s+(?<target2>\\w+)', 'gm')
const str = ` john smith (ABCDEFG) <js@email.com>
target1 = 3333, j
target2 1111,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}