// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)target1 = (?<target1>\w+).*\ntarget2\s+(?<target2>\w+)").unwrap();
let string = " john smith (ABCDEFG) <js@email.com>
target1 = 3333, j
target2 1111,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}