$re = '/target1 = (?<target1>\w+).*\ntarget2\s+(?<target2>\w+)/m';
$str = ' john smith (ABCDEFG) <js@email.com>
target1 = 3333, j
target2 1111,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);