package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)target1 = (?<target1>\w+).*\ntarget2\s+(?<target2>\w+)`)
var str = ` john smith (ABCDEFG) <js@email.com>
target1 = 3333, j
target2 1111,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}