re = /target1 = (?<target1>\w+).*\ntarget2\s+(?<target2>\w+)/m
str = ' john smith (ABCDEFG) <js@email.com>
target1 = 3333, j
target2 1111,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end