#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(https?:\/\/)?([w]{3}\.)?(\w*.\w*)([\/\w]*)"
Local $sString = "https://www.facebook.org/hello" & @CRLF & _
"http://www.xxxx.wordpress.com/hello" & @CRLF & _
"http://www.xxxx.yyy.zzz.wordpress.com/hello"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)