import re
regex = re.compile(r"(https?:\/\/)?([w]{3}\.)?(\w*.\w*)([\/\w]*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("https://www.facebook.org/hello\n"
"http://www.xxxx.wordpress.com/hello\n"
"http://www.xxxx.yyy.zzz.wordpress.com/hello")
subst = "$3"
result = regex.sub(subst, test_str)
if result:
print(result)