re = /(https?:\/\/)?([w]{3}\.)?(\w*.\w*)([\/\w]*)/mi
str = 'https://www.facebook.org/hello
http://www.xxxx.wordpress.com/hello
http://www.xxxx.yyy.zzz.wordpress.com/hello'
subst = '$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result