const regex = new RegExp('(https?:\\/\\/)?([w]{3}\\.)?(\\w*.\\w*)([\\/\\w]*)', 'gmi')
const str = `https://www.facebook.org/hello
http://www.xxxx.wordpress.com/hello
http://www.xxxx.yyy.zzz.wordpress.com/hello`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);