package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(https?:\/\/)?([w]{3}\.)?(\w*.\w*)([\/\w]*)`)
var str = `https://www.facebook.org/hello
http://www.xxxx.wordpress.com/hello
http://www.xxxx.yyy.zzz.wordpress.com/hello`
var substitution = "$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}