#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)\d{4,6}(?!\d)"
Local $sString = "1234" & @CRLF & _
"56789" & @CRLF & _
"566678" & @CRLF & _
"/566678/" & @CRLF & _
"abc-1234-555" & @CRLF & _
"" & @CRLF & _
"a1234b" & @CRLF & _
"01234b" & @CRLF & _
"1234b" & @CRLF & _
"_1234_" & @CRLF & _
"" & @CRLF & _
"1234477" & @CRLF & _
"123" & @CRLF & _
"12" & @CRLF & _
"1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")