use strict;
my $str = '1234
56789
566678
/566678/
abc-1234-555
a1234b
01234b
1234b
_1234_
1234477
123
12
1';
my $regex = qr/(?<!\d)\d{4,6}(?!\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}