import re
regex = re.compile(r"(?<!\d)\d{4,6}(?!\d)", flags=re.MULTILINE)
test_str = ("1234\n"
"56789\n"
"566678\n"
"/566678/\n"
"abc-1234-555\n\n"
"a1234b\n"
"01234b\n"
"1234b\n"
"_1234_\n\n"
"1234477\n"
"123\n"
"12\n"
"1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")