re = /(?<!\d)\d{4,6}(?!\d)/m
str = '1234
56789
566678
/566678/
abc-1234-555
a1234b
01234b
1234b
_1234_
1234477
123
12
1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end