import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)\\d{4,6}(?!\\d)";
final String string = "1234\n"
+ "56789\n"
+ "566678\n"
+ "/566678/\n"
+ "abc-1234-555\n\n"
+ "a1234b\n"
+ "01234b\n"
+ "1234b\n"
+ "_1234_\n\n"
+ "1234477\n"
+ "123\n"
+ "12\n"
+ "1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}