using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)\d{4,6}(?!\d)";
string input = @"1234
56789
566678
/566678/
abc-1234-555
a1234b
01234b
1234b
_1234_
1234477
123
12
1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}