#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(https?:\/\/[^\/]+)\/(.*)"
Local $sString = "1) http://localhost:8800/" & @CRLF & _
"" & @CRLF & _
"2) http://localhost:8800/About.aspx" & @CRLF & _
"" & @CRLF & _
"3) http://localhost:8800/product.aspx?id=1&vref=201" & @CRLF & _
"" & @CRLF & _
"4) http://localhost:8800/Contact.aspx" & @CRLF & _
"" & @CRLF & _
"5) http://localhost:8800/Contact/india " & @CRLF & _
"" & @CRLF & _
"6) http://localhost:8800/Contact/usa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")