package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?:\/\/[^\/]+)\/(.*)`)
var str = `1) http://localhost:8800/
2) http://localhost:8800/About.aspx
3) http://localhost:8800/product.aspx?id=1&vref=201
4) http://localhost:8800/Contact.aspx
5) http://localhost:8800/Contact/india
6) http://localhost:8800/Contact/usa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}