use strict;
my $str = '1) http://localhost:8800/
2) http://localhost:8800/About.aspx
3) http://localhost:8800/product.aspx?id=1&vref=201
4) http://localhost:8800/Contact.aspx
5) http://localhost:8800/Contact/india
6) http://localhost:8800/Contact/usa';
my $regex = qr/(https?:\/\/[^\/]+)\/(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}