// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?:\/\/[^\/]+)\/(.*)").unwrap();
let string = "1) http://localhost:8800/
2) http://localhost:8800/About.aspx
3) http://localhost:8800/product.aspx?id=1&vref=201
4) http://localhost:8800/Contact.aspx
5) http://localhost:8800/Contact/india
6) http://localhost:8800/Contact/usa";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}