$re = '/(https?:\/\/[^\/]+)\/(.*)/';
$str = '1) http://localhost:8800/
2) http://localhost:8800/About.aspx
3) http://localhost:8800/product.aspx?id=1&vref=201
4) http://localhost:8800/Contact.aspx
5) http://localhost:8800/Contact/india
6) http://localhost:8800/Contact/usa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);