using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/[^\/]+)\/(.*)";
string input = @"1) http://localhost:8800/
2) http://localhost:8800/About.aspx
3) http://localhost:8800/product.aspx?id=1&vref=201
4) http://localhost:8800/Contact.aspx
5) http://localhost:8800/Contact/india
6) http://localhost:8800/Contact/usa";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}