#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=Length)(.*)(?<=program)"
Local $sString = " <h2 id='PO-PF2' class="section">Program Information</h2>" & @CRLF & _
" Length: Two-year Ontario College Graduate Certificate program" & @CRLF & _
" <br />Delivery Sequence:<br />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")