$re = '/(?=Length)(.*)(?<=program)/m';
$str = ' <h2 id=\'PO-PF2\' class="section">Program Information</h2>
Length: Two-year Ontario College Graduate Certificate program
<br />Delivery Sequence:<br />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);