import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=Length)(.*)(?<=program)";
final String string = " <h2 id='PO-PF2' class=\"section\">Program Information</h2>\n"
+ " Length: Two-year Ontario College Graduate Certificate program\n"
+ " <br />Delivery Sequence:<br />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}