const regex = new RegExp('(?=Length)(.*)(?<=program)', 'gm')
const str = ` <h2 id='PO-PF2' class="section">Program Information</h2>
Length: Two-year Ontario College Graduate Certificate program
<br />Delivery Sequence:<br />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}