re = /(?=Length)(.*)(?<=program)/m
str = ' <h2 id=\'PO-PF2\' class="section">Program Information</h2>
Length: Two-year Ontario College Graduate Certificate program
<br />Delivery Sequence:<br />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end