using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=Length)(.*)(?<=program)";
string input = @" <h2 id='PO-PF2' class=""section"">Program Information</h2>
Length: Two-year Ontario College Graduate Certificate program
<br />Delivery Sequence:<br />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}