#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w*<(.*(?:(?:R)|))>"
Local $sString = "aaa<123>" & @CRLF & _
"bbb<456;789>" & @CRLF & _
"ccc<aaa<123>;bbb<456;789>>" & @CRLF & _
"ccc<aaa<123>;bbb<456;ccc<aaa<123>;bbb<456;789>>>>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")