package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w*<(.*(?:(?:R)|))>`)
var str = `aaa<123>
bbb<456;789>
ccc<aaa<123>;bbb<456;789>>
ccc<aaa<123>;bbb<456;ccc<aaa<123>;bbb<456;789>>>>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}