re = /\w*<(.*(?:(?:R)|))>/
str = 'aaa<123>
bbb<456;789>
ccc<aaa<123>;bbb<456;789>>
ccc<aaa<123>;bbb<456;ccc<aaa<123>;bbb<456;789>>>>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end