using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w*<(.*(?:(?:R)|))>";
string input = @"aaa<123>
bbb<456;789>
ccc<aaa<123>;bbb<456;789>>
ccc<aaa<123>;bbb<456;ccc<aaa<123>;bbb<456;789>>>>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}