import re
regex = re.compile(r"\w*<(.*(?:(?:R)|))>")
test_str = ("aaa<123>\n"
"bbb<456;789>\n"
"ccc<aaa<123>;bbb<456;789>>\n"
"ccc<aaa<123>;bbb<456;ccc<aaa<123>;bbb<456;789>>>>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")