$re = '/\w*<(.*(?:(?:R)|))>/';
$str = 'aaa<123>
bbb<456;789>
ccc<aaa<123>;bbb<456;789>>
ccc<aaa<123>;bbb<456;ccc<aaa<123>;bbb<456;789>>>>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);