#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:.+V)([0-9.]+)(?:.+|$)"
Local $sString = "A12 V1.1" & @CRLF & _
"A9 V2.3 8.99" & @CRLF & _
"A34 8.3 V4"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)