const regex = /(?:.+V)([0-9.]+)(?:.+|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.+V)([0-9.]+)(?:.+|$)', 'gm')
const str = `A12 V1.1
A9 V2.3 8.99
A34 8.3 V4`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);